Member Offer
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Epson Perfection 2480 Photo

Discussion in 'General Software & Hardware Forum:' started by Jimlad, Jan 17, 2011.

  1. Jimlad

    Jimlad Well-Known Member

    I've had this scanner since... oh I dunno... 2003?
    Brillant scanner, top quality, even has a negative-scanner in it.
    It worked with Windows XP, Mac OS X Leopard, and after installing the right drivers and Rosetta it worked fine on Snow Leopard too.

    So, has anyone got a clue why I'm getting this screen tonight when it does the overview scan?
    Thanks for any advice given. I hope it's not kaput for no good reason.

    [​IMG]
     
  2. Thewholehogg

    Thewholehogg Active Member

    Usual, run permissions in Disk Utilities.
    Check your drivers are upto date.
    Are you running the USB from the Mac or through a hub?
    Is the scanner getting enough juice?
    Check the USB cable.

    I can get you a new scanner..cheap as chips.
     
  3. Jimlad

    Jimlad Well-Known Member

    Everything is as it was last time I used it with no problem... USB through a hub, plenty juice, drivers are up to date. Inexplicable. I may run the permissions and whatnot. Onyx is sitting looking at me begging to be clicked on. That never solves anything though.
     
  4. Levi

    Levi Moderator Staff Member

    could be the usb cable, try running directly connected to mac to rule out hub.

    I get it occasionally on windows with an external hard drive and it's usually just a case of unplug and replug the usb cable or turn the external drive off and then on again. It's one of those little annoyances you get with usb...
     
  5. Thewholehogg

    Thewholehogg Active Member

    Didn't I mention that?
     
  6. Levi

    Levi Moderator Staff Member

    only the cable possibly being the problem, you asked a question about the hub :p
     
  7. Thewholehogg

    Thewholehogg Active Member

    ...getting enough juice....or power.

    anyways moving on.
     
  8. Jimlad

    Jimlad Well-Known Member

    Since when were scanners powered by the USB? It's got a grown-up power supply with a mains plug...
     
  9. Levi

    Levi Moderator Staff Member

    since about 2000AD if not a bit before :p
     
  10. Jimlad

    Jimlad Well-Known Member

    I'm afraid none of this is working... I haven't bought a scanner in years! Any recommendations? Preferably Snow Leopard compatible.
     
  11. Jimlad

    Jimlad Well-Known Member

    Further info about this problem, I've tried it with different USB leads in different ports and they all give the same error message.

    Then I plug it into my mum's old iBook and it works no problem!

    I was almost going to go and buy a scanner today but now Im not so sure. Is there anything else I can do to try and fix this? I've removed the scanner from the preferences screen and added it again, I've reinstalled drivers, I've run Onyx. What else is there to do on a Mac???
     

Share This Page