Member Offer
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Epson and Snow Leopard don't get along it seems.

Discussion in 'General Software & Hardware Forum:' started by Jimlad, Nov 26, 2009.

Thread Status:
Not open for further replies.
  1. Jimlad

    Jimlad Well-Known Member

    I own an Intel iMac, it ran OS 10.5 Leopard, and life was good.
    Apple told me to, so I upgraded to OS 10.6 Snow Leopard and installed Rosetta, and now my Epson R300 has become a stunted anti-social version of itself.

    The Utilities app wouldn't work, and I use that to check the ink, so I downloaded the latest driver pack for OS 10.6, and have since discovered that Utilities 2 doesn't even see the printer (which does still print from apps), and when I print in Photoshop it seems to have completely lost the ability to print borderless!

    That is a major problem.

    Has anyone else encountered problems between Epson and Snow Leopard? Anyone know how to restore my Printer to its former usefulness? Any insight would help.
  2. tim

    tim Senior Member

    you searched for new drivers on ?
  3. Jimlad

    Jimlad Well-Known Member

    I got new drivers on the Epson website. Maybe I'll try apple tomorrow, but the ones on the Epson site were meant to be for SL.
  4. Jimlad

    Jimlad Well-Known Member

    Ok this issue has been solved!

    Removing and installing those drivers twice did nothing. Removing and adding the printer did nothing.
    But I discovered a brilliant little chat system on the Epson website, and in a few minutes the problem was sorted.
    Seems that although I had the right drivers, the printer was still using a different set for some reason*. And the new drivers weren't available to even select on the list for quite a while, then they appeared inexplicably. So this thread can probably be closed now.

    *There it is again.
  5. glenwheeler

    glenwheeler Senior Member

    Uninstall all the device's drivers and download the new drivers direct and try that. I had a simular problem with windows 7
  6. Jimlad

    Jimlad Well-Known Member

    Thanks glenwheeler but the problem's sorted now. And I had tried that, twice. Turns out the mac just decided not to use them.
  7. glenwheeler

    glenwheeler Senior Member

    oh right excellent great news mate, glad its sorted
Thread Status:
Not open for further replies.

Share This Page