Epson 9800 died suddenly after black ink swap


New Member
Hi all,

I hope that some of you guys can give me a direction where to look at regarding this problem.

I have an Epson 9800 on photo black ink. It's always been printing perfectly without a single problem at all, until last night.. I decided to give a try with the matt black ink, so I did a ink change. I followed the official method, ie, flushing hundred pounds of ink and used the black conversion kit. When everything was done, I tried to print something, then it turned out printing nothing.. :(

I tried both printing from the printer command panel and from the computer, the printhead carriage was moving and no error message appeared, then I tried a number of initial fill from the servicing menu, then a number of ink swap, but I noticed that the right maintenance tank was never used (I installed a new one as the consequence of the constant ink swapping & cleaning).. I also noticed that some air gaps are in the black tube which did not get fill up after all these fill and swaps... Also the ink bubbles did not move at all.

It is weird because even until the moment before I swapped ink the printer printed perfectly, as I am a regular user of this printer.

I read some forums that the printhead or the pump might be gone.. but no error message saying that?

I would be greatly appreciate any ideas you guys may have. Thanks in advance, and hope I don't have to spend a fortune on replacing this and that.. :(