Print Reseller Scheme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spry Menu SubMenu doesn't show up

Discussion in 'Website Coding & Programming Forum:' started by Mattdbryce, Jan 28, 2013.

  1. Mattdbryce

    Mattdbryce Member

    Hey guys,

    Just working on this website at the moment - Good Tatse -

    And i'm having a bit of trouble with getting the "Products" sub menu on the sprymenu to show up. It works fine in dreamweaver design view, however disappears when previewed in browser.

    I'm supposed to show this today for a job application, so any help would be greatly appreciated!

    Thanks guys,

    Matt
     
  2. Stationery Direct

    Stationery Direct Administrator Staff Member

    Not sure how to fix that although it doesn't work here either, i'm sure Corrosive will answer that, also amend the typo in the title tag.
     
  3. Corrosive

    Corrosive Moderator Staff Member

    *shudder* Spry huh? Looks like it might be disappearing behind your rotating banner/image widget. Perhaps have a look at some z-index values to see if you can stick the rotator behind the dropdown.
     
  4. Mattdbryce

    Mattdbryce Member

    Oooh, is spry a bad idea? Is there a better way to navigate the site? Thanks i will check the z index now.
     
  5. Mattdbryce

    Mattdbryce Member

    I have placed the image rotater in a div called "imagebox" and i've set the z-index on "imagebox" to 1. The spry menu is in a div called "nav" and placed above the "imagebox" div, i've set the z-index to 2 and there is no change on the sub menu. Am I using the z-index wrong? Forgive my noob-ability!

    Matt
     
  6. Corrosive

    Corrosive Moderator Staff Member

    Spry was just kinda 'of the moment' back when CS3 was new and never really developed as coders knew their were more elegant solutions and non-coders just ended up being baffled. I mod a Dreamweaver forum as well and we still get loads of questions about why Spry is so flaky cross-browser. So I would check it in as many different browsers (including legacy versions) that you can get your hands on or find a better solution for dropdowns. Perhaps something pure CSS or JQuery based might be better.
     
  7. Corrosive

    Corrosive Moderator Staff Member

    Try setting #rotating-item-wrapper to a -1 z-index and see what that does.
     
  8. Mattdbryce

    Mattdbryce Member

    The rotating image box has disappeared after setting #rotating-item-wrapper to -1. I would like to get this working and then try and figure out a JQuery nav when i have more time. Unless it's easy!? Might i still have the same problem?

    I'll keep playing around with z-index, any other ideas?

    Thanks

    Matt
     
  9. Mattdbryce

    Mattdbryce Member

    Keep getting this error message too, anything to dowith it?

    error.jpg
     
  10. Corrosive

    Corrosive Moderator Staff Member

    No, that is a mismatch between your page and your DW Template areas. For simple dropdowns you could go Suckerfish; Son of Suckerfish Dropdowns | HTML Dog You could also try adjusting/adding the z-index to the code that relates to the dropdown portion of your menu rather than the #nav itself. Really difficult to say as the code produced by Spry is BLOATED :icon_confused: beyond belief (like most of Dreamweaver's WYSIWYG code to be honest) and I find it hard to decipher what the hell is going on with it.
     
    Katedesign likes this.
  11. Mattdbryce

    Mattdbryce Member

    Oh i see, great thanks, i'll have more of a play and let you know if i'm successful.

    Is there a way i can get the dotted borders on the sidebars to reach the bottom of the page? They stop short.

    Thanks

    Matt
     
  12. Katedesign

    Katedesign Well-Known Member

    Corrosive has just helped me to sort out a html and css drop down (Thanks very much!) and I am now trying to unpick a form done in Dreamweaver...more like Nightmareweaver....
     

Share This Page