Print Reseller Scheme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Small Image Issue

Discussion in 'Website Design Forum:' started by RossAdams, Jun 4, 2009.

  1. RossAdams

    RossAdams Member

    If any help can be provided it would be appreciated. Probably me doing something daft but I've tried to add some small icons to my sidebar but they seem to have a grey background. The Icons are PNG files and have no background on them?

    Using dreamweaver CS4

  2. glenwheeler

    glenwheeler Senior Member

    Could you not work round it a add a background to them to what you prefer instead of no background?
  3. tim

    tim Senior Member

    Is the error still there when you preview it in FF3 or Safari 4 or IE7/8 ? Normally, DW would do that for me until I pressed preview.
  4. Levi

    Levi Moderator Staff Member

    you did tick transparent backgrounds before (in photoshop) exporting to web png didn't you :)

    Second does the browser actually support png transparency (most new ones should but ie6 doesn't :()
  5. br3n

    br3n Senior Member

    I was thinking the tick box as well... try a transparent gif just to see if it works?
  6. RossAdams

    RossAdams Member

    The icons still have the grey background when viewing it in my browser, they definitely have a transparent background. Is it not possible to import a PNG image file without dreamweaver adding a background?

    Or is it possible for me to change to grey it currently displays to the colour of the page background so it isn't seen.

    Surely it must be possible to add an icon without dreamweaver adding a background to it??
  7. glenwheeler

    glenwheeler Senior Member

    Why cant you add a background colour to the file just in photoshop? and save it as a Jpeg or GIF?
  8. RossAdams

    RossAdams Member

    I think i'll have to, just can't believe that you can't import a image file and it not display the transparent background??
  9. Levi

    Levi Moderator Staff Member

    you can (and I have), but you have to tick a box that says transparent background (atleast I do in photoshop) when you export for web.

    Have you tried the gif option as suggested too.
  10. Kevin

    Kevin Senior Member

    Err... probably shouldn't blame Dreamweaver. Something went wrong while saving, try flattening your layers and resave (might want to back-up the psd so you still have the layers afterwards).

Share This Page