• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lightbox help!!!!


mrkidd85

Junior Member
#1
I wish to use lightboxes for a site I am making, however I have been getting very frustrated as I have followed the code exactly, but am not getting the desired effect. I have started a page on angelfire to see if I can resolve the problem here.

Here is the code,

CSS

#lightbox{ position: absolute; left: 0; width: 100%; z-index: 100; text-align: center; line-height: 0;}
#lightbox img{ width: auto; height: auto;}
#lightbox a img{ border: none; }
#outerImageContainer{ position: relative; background-color: #fff; width: 250px; height: 250px; margin: 0 auto; }
#imageContainer{ padding: 10px; }
#loading{ position: absolute; top: 40%; left: 0%; height: 25%; width: 100%; text-align: center; line-height: 0; }
#hoverNav{ position: absolute; top: 0; left: 0; height: 100%; width: 100%; z-index: 10; }
#imageContainer>#hoverNav{ left: 0;}
#hoverNav a{ outline: none;}
#prevLink, #nextLink{ width: 49%; height: 100%; background-image: url(data:image/gif;base64,AAAA); /* Trick IE into showing hover */ display: block; }
#prevLink { left: 0; float: left;}
#nextLink { right: 0; float: right;}
#prevLink:hover, #prevLink:visited:hover { background: url(../images/prevlabel.gif) left 15% no-repeat; }
#nextLink:hover, #nextLink:visited:hover { background: url(../images/nextlabel.gif) right 15% no-repeat; }
#imageDataContainer{ font: 10px Verdana, Helvetica, sans-serif; background-color: #fff; margin: 0 auto; line-height: 1.4em; overflow: auto; width: 100% ; }
#imageData{ padding:0 10px; color: #666; }
#imageData #imageDetails{ width: 70%; float: left; text-align: left; }
#imageData #caption{ font-weight: bold; }
#imageData #numberDisplay{ display: block; clear: left; padding-bottom: 1.0em; }
#imageData #bottomNavClose{ width: 66px; float: right; padding-bottom: 0.7em; outline: none;}
#overlay{ position: absolute; top: 0; left: 0; z-index: 90; width: 100%; height: 500px; background-color: #000; }

HTML

<html><head>
<link rel="stylesheet" href="css/lightbox.css" type="text/css" media="screen" />

<script type="text/javascript" src="js/prototype.js"></script>
<script type="text/javascript" src="js/scriptaculous.js?load=effects,builder"></script>
<script type="text/javascript" src="js/lightbox.js"></script>

<body>

<a href="images/image-1.jpg" rel="lightbox[roadtrip]"><img src="images/image-1.jpg"</a>
<a href="images/image-1.jpg" rel="lightbox[roadtrip]"><img src="images/image-1.jpg"</a>
<a href="images/image-1.jpg" rel="lightbox[roadtrip]"><img src="images/image-1.jpg"</a>
<a href="images/image-1.jpg" rel="lightbox[roadtrip]"><img src="images/image-1.jpg"</a>

</body>
</html>
You will find the page at http://www.angelfire.com/westcountrydental/lightbox.html .

Also, I have downloaded a debugging system for Internet Explorer and it is flashing up on my screen saying there is an error on line 4391 character 3, and line 4435 character 9. I don't understand what this means.

Can somebody please help me because I really want to get this site finished now. And before anybody asks, I am only using these pics as an example.
 

Levi

Moderator
Staff member
#2
The lightbox looks like it's missing one of the required files to make it overlay (probably a js file), the image pops up lower down the page.

Check to make sure you have all the relevant files needed linked in the header text.

Edit: assuming its the lightbox from dynamic drive try changing the
Code:
<script type="text/javascript" src="[URL="http://www.designforums.co.uk/view-source:http://www.angelfire.com/westcountrydental/js/scriptaculous.js?load=effects,builder"]js/scriptaculous.js?load=effects,builder[/URL]"></script>
to
Code:
<script type="text/javascript" src="[URL="http://www.designforums.co.uk/view-source:http://www.angelfire.com/westcountrydental/js/scriptaculous.js?load=effects,builder"]js/scriptaculous.js?load=effects[/URL]"></script>