Print Reseller Scheme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IT help required - SMTP email settings and BT Business internet

Discussion in 'Chill Out Forum:' started by leepaulvickersdesign, Aug 30, 2012.

  1. Can anyone help me out with a frustrating email problem I'm having?

    I have just moved office and now having problems with outgoing email; I have a personal email account (Apple .mac) and business email account (vickerscreative.co.uk, professionally hosted) and a desktop mail client (Apple Mail app) set up as IMAP. Everything worked ok at the previous premises using PlusNet, but at the new premises with BT Business the Mail app can't connect to the vickerscreative.co.uk outgoing email account using SMTP. The vickerscreative.co.uk incoming mail (IMAP) is ok, as is the Apple .mac email.

    The SMTP settings are:
    Server: mail.vickerscreative.co.uk
    Ports: Default (25, 465, 587)
    No SSL
    Authentication type: Password

    I've tried all the other authentication types (TLS certificate, Kerberos, NTLM & MD5) SSL/non-SSL, and a combination of all of them, none of which allow Mail to connect.

    The strange thing is I can send email from the vickerscreative.co.uk account from my HTC smartphone using the same BT Business connection, just not from the desktop.

    I think it's something to do with the ports for the outgoing mail, but before I tackle the BT shunt to get some numbers out of them, I thought I would ask here for some wisdom.

    Cheers, Lee
     
  2. Levi

    Levi Moderator Staff Member

    yeah it does sound more port related....

    Check these -
    -if you have any firewalls active on desktop and router
    -upnp is enabled, this just does everything for you rather than you dealing with the ports
    -confirm all the mail settings, it's possible you may have changed the mail settings somewhere to the wrong ones

    I'll say now though that this is not a bt issue, this is computer/router which is causing the issue.
     
  3. Thanks Levi

    Connecting still fails with the Firewall turned off
    There are no upnp setting for the Apple Mail client app
    The connection failed as soon as I launched the Mail app in the new premises

    Someone has suggested contacting BT to enable third-party SMTP servers on our account which is what we're currently trying.
     
  4. openmind

    openmind Senior Member

    That's exactly what you need to do as it's highly likely that outgoing smtp connections are being blocked by BT. The other option is to not send mail through your domain but use the BT Business SMTP server instead. The latter is probably the easiest solution...
     
  5. Bt say there's nothing stopping me from accessing my mail server over SMTP... I've found a list of BT mail server addresses but non of those seem to work either. They say BT use port 995 for outgoing mail but even then no luck!

    Seems odd that BT business make it really difficult for their customers to access privately hosted mail servers...
     
  6. openmind

    openmind Senior Member

    Are you using Windows or a Mac?
     
  7. Mac & Mail app. Shouldn't matter though should it?
     
  8. openmind

    openmind Senior Member

    Not at all but I just want to check which ports are open and listening. Can you open a Mac terminal and enter this command:

    lsof -i -P | grep -i "listen"

    Then copy and paste the results here...
     
  9. Thanks openmind!

    EEventMan 346 leepaulvickers 4u IPv4 0xffffff8012a1ea40 0t0 TCP *:2968 (LISTEN)
    Dropbox 348 leepaulvickers 19u IPv4 0xffffff8012a1f160 0t0 TCP *:17500 (LISTEN)
    Dropbox 348 leepaulvickers 25u IPv4 0xffffff80159b5320 0t0 TCP localhost:26164 (LISTEN)
    iTunes 1328 leepaulvickers 28u IPv4 0xffffff8026561c20 0t0 TCP *:3689 (LISTEN)
    iTunes 1328 leepaulvickers 29u IPv6 0xffffff8015ffb240 0t0 TCP *:3689 (LISTEN)
    Last.fm 1332 leepaulvickers 11u IPv4 0xffffff80256aec20 0t0 TCP localhost:32213 (LISTEN)
    Last.fm 1332 leepaulvickers 16u IPv4 0xffffff8012a1d4e0 0t0 TCP localhost:33367 (LISTEN)
    SwitchBoa 1335 leepaulvickers 10u IPv4 0xffffff8013251c00 0t0 TCP localhost:3705 (LISTEN)
     
  10. openmind

    openmind Senior Member

    Well you're not listening on any of the normal ports for smtp.

    Can you go back to the mac terminal and enter:

    telnet mail.btconnect.com 25

    You should get a welcome message like "220 mail.btconnect.com ESMTP"
     
  11. Still trying... this is what I have so far:

    Trying 213.123.20.93...
    Connected to obmr.btconnect.com.
    Escape character is '^]'.
    220 mail.btconnect.com ESMTP
     
  12. openmind

    openmind Senior Member

    OK that's progress as you can connect to btconnect on port 25 ;)

    Now on the Mac SMTP settings use mail.btconnect.com as the server, port 25 with no SSL and don't use authentication.

    If that fails then shout at BT :)
     
  13. Good news is that Mail successfully connected to the BT mail server.

    Bad news is sending a test mail failed: "The sender address lee@vickerscreative.co.uk was rejected by the server mail.btconnect.com."
     
  14. openmind

    openmind Senior Member

    Thought that may happen, BT is rejecting the email based on your domain. This is something they will need to set to allowed but the fact you can connect is good, a simple tweak at BTs end should resolve it completely.
     
  15. So I just need to ask them to 'allow my domain on their mail server'?
     
  16. openmind

    openmind Senior Member

    Yep just tell them that you can connect fine to mail.btconnect.com on port 25 and give them that exact error. Don't mention the word Mac as it will confuse them Hopefully you will get someone with a brain ;)
     
  17. Thanks for the help, much appreciated! Too busy to look into this today, might even be next week, but will post back.

    Next time I'm in Edinburgh I'll buy you a pint :)
     
  18. openmind

    openmind Senior Member

    No worries :)
     

Share This Page