• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

footer issues.. again...


C

chrismitchell

Guest
#1
Can anyone see why my footer wouldn't be showing?

Code:
<?php/** * @package WordPress * @subpackage Default_Theme */?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>><head profile="http://gmpg.org/xfn/11"><meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" /><title><?php wp_title('&laquo;', true, 'right'); ?> <?php bloginfo('name'); ?></title><link href="http://creative.widdlerswee.co.uk/wp-content/themes/widdlers3/style.css" rel="stylesheet" type="text/css" media="screen" /><link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" /><link rel="Shortcut Icon" href="http://www.widdlerswee.co.uk/favicon.ico" /><?php wp_head(); ?><script type="text/javascript" src="http://creative.widdlerswee.co.uk/wp-content/themes/widdlers2/js/script.js"></script><script type="text/javascript">  var _gaq = _gaq || [];  _gaq.push(['_setAccount', 'UA-9617644-1']);  _gaq.push(['_trackPageview']);  (function() {    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);  })();</script><script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js"></script><script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.2/jquery-ui.min.js"></script></head><body><div id="header"></div>    <div id="main">    	<div id="logo" onclick="location.href='http://creative.widdlerswee.co.uk';" style="cursor:pointer;"></div>        <div id="quotebutton" onclick="location.href='http://creative.widdlerswee.co.uk/quoterequest';" style="curson:pointer;"></div>        <div id="contactmenu">        <ul>        	<li><a href="mailto:letstalk@widdlerswee.co.uk?subject=Hey Widdlerswee Creative, Lets Talk!">letstalk@widdlerswee.co.uk</a></li>        	<li><a href="http://twitter.com/widdlerswee">@widdlerswee</a></li>        </ul>        </div>		<div id="menu">        	<ul>     			<li><a href="http://creative.widdlerswee.co.uk/webdesign">web design</a> |</li>     			<li><a href="http://creative.widdlerswee.co.uk/printdesign">print design</a> |</li>     			<li><a href="http://creative.widdlerswee.co.uk/portfolio">portfolio</a> |</li>     			<li><a href="http://creative.widdlerswee.co.uk/blog">blog</a> |</li>     			<li><a href="http://creative.widdlerswee.co.uk/contact">lets talk</a></li>     		</ul>          	</div><div id="menubottom"></div><?php get_header(); ?><div id="container"><div id="latestproject"><div id="latestprojecttitle">Latest Project</div></div><div id="section2"><div id="twitter"><div id="twitterbubble"><div id="followtext"><?php twitter_messages("widdlerswee"); ?></div></div><div id="follow">Follow <a href="http://twitter.com/widdlerswee">@widdlerswee</a> on twitter</div></div><div id="blog">	<h2>blog</h2><?php query_posts('category_name=blog&posts_per_page=1'); ?>	<?php while (have_posts()) : the_post(); ?>	<strong><a href="<?php the_permalink(); ?>"><?php the_title(); ?></a></strong>	<br>	<?php the_excerpt(); ?><?php endwhile; ?></div><br/> 		<?php get_footer(); ?><?php wp_footer(); ?><div id="footer"><div id="footerleft"><?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('FooterLeft') ) : ?><br />Copyright © 2010 <a href="http://creative.widdlerswee.co.uk">WiddlersWee Creative</a></div><div id="footerright">                  <?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('FooterRight') ) : ?></div></div></body></html>
for some reason or another its just not showing the <?php get_footer(); ?> at all which is very weird.
 

Harry

Senior Member
#4
I tend not to use the get_footer bollocks that WP offers, because their code is absolutely disgusting.

I opt for just including the files instead, works every time for me.
 
C

chrismitchell

Guest
#6
Also for some reason my SEO thingy is making it say Blog on my title instead of Welcome... which makes me think i've done something very VERY wrong :eek:
 

Harry

Senior Member
#8
Sorry, forgot to check back. Were they jusy PHP errors then?

I hate that WP uses the endif syntax—makes much less sense to me than a }
 
C

chrismitchell

Guest
#9
yeah it was just the endif syntax was missing from one call (which I thought I had already ended elsewhere) which threw out the whole footer..

All I want to do is update my portfolio site :) :lol: its not too much to ask LOL