Deployment failed: no _dump_data is defined for class Enumerator


HippySunshine

Senior Member
Since updating my mac to Catalina, I'm having serious problems with deployment.
I'm hoping someone here has the knowledge I'm misisng as I've hit a brick wall and Google is no longer helping.

In terminal, I'm running
Code:
cap uat deploy branch=release/4.0.0
- This should deploy my local changes from release/4.0.0 to UAT (staging site).
Instead, I'm getting the following error:


Code:
...
(Backtrace restricted to imported tasks)
cap aborted!
TypeError: no _dump_data is defined for class Enumerator

Tasks: TOP => rsync:create_release => rsync:release
(See full trace by running task with --trace)
The deploy has failed with an error: no _dump_data is defined for class Enumerator


** DEPLOY FAILED
** Refer to log/capistrano.log for details. Here are the last 20 lines:


  INFO [48d8ce56] Finished in 0.110 seconds with exit status 0 (successful).

 DEBUG [5fe5c207] Running [ -f /home/xxxx/capistrano_uat/shared/.htaccess ] as xxxx@xxx.xxx.xx.xx

 DEBUG [5fe5c207] Command: [ -f /home/xxxx/capistrano_uat/shared/.htaccess ]

 DEBUG [5fe5c207] Finished in 0.110 seconds with exit status 0 (successful).

 DEBUG [91d12373] Running [ -f /home/xxxx/capistrano_uat/shared/wp-config.php ] as xxxx@185.xxx.xx.xx

 DEBUG [91d12373] Command: [ -f /home/xxxx/capistrano_uat/shared/wp-config.php ]

 DEBUG [91d12373] Finished in 0.110 seconds with exit status 0 (successful).

 DEBUG [eed79024] Running [ -f /home/xxxx/capistrano_uat/shared/awards-winner.png ] as xxxx@xxx.xxx.xx.xx

 DEBUG [eed79024] Command: [ -f /home/xxxx/capistrano_uat/shared/awards-winner.png ]

 DEBUG [eed79024] Finished in 0.109 seconds with exit status 0 (successful).

 DEBUG [8bb292a4] Running [ -f /home/xxxx/capistrano_uat/shared/rar-recommended.png ] as xxxx@xxx.xxx.xx.xx

 DEBUG [8bb292a4] Command: [ -f /home/xxxx/capistrano_uat/shared/rar-recommended.png ]

 DEBUG [8bb292a4] Finished in 0.110 seconds with exit status 0 (successful).

 DEBUG [134b2ada] Running [ -f /home/xxxx/capistrano_uat/current/REVISION ] as xxxx@xxx.xxx.xx.xx

 DEBUG [134b2ada] Command: [ -f /home/xxxx/capistrano_uat/current/REVISION ]

 DEBUG [134b2ada] Finished in 0.109 seconds with exit status 0 (successful).

 DEBUG [b142445e] Running /usr/bin/env cat /home/xxxx/capistrano_uat/current/REVISION 2>/dev/null as xxxx@xxx.xxx.xx.xx

 DEBUG [b142445e] Command: /usr/bin/env cat /home/xxxx/capistrano_uat/current/REVISION 2>/dev/null

 DEBUG [b142445e]     a61943df88d68ca6309b1886c140d86bad68ac59

 DEBUG [b142445e] Finished in 0.116 seconds with exit status 0 (successful).
I've exhausted all the recommendations that I can find on Google :(
Please help.
 

fisicx

Active Member
What are you uploading? The whole database or just the site files?

The reason I ask is there much easier ways to upload to a server. SVN and FTP for example.
 

HippySunshine

Senior Member
What are you uploading? The whole database or just the site files?

The reason I ask is there much easier ways to upload to a server. SVN and FTP for example.
FTP isn't exactly the safest approach, and I'm not looking for an alternative deployment process (what I have works fine - prior to the Catalina update), I just need to fix why my deploy is failing and get rid of this error.
 
Top